knopka



Проблемы при установке

Возможные ошибки и глюки при установке тем.

В ряде случае, после загрузки файлов на сайт и при попытке обновиться, Вы можете столкнуться с тем, что вместо корректного отображения сайта получаете сообщение об ошибке, которое передает сервер. Что-то типа этого:

Warning: Cannot modify header information — headers already sent by….

Эта ошибка означает предупреждение системы, что в каком-то из файлов, загруженных Вами на сайт, установлена кодировка, которая не поддерживается. Как правило, WP блоги работают в кодировке UTF-8. Соответственно, файлы темы, которые Вы загрузили в wp-content/themes, также должны быть в кодировке UTF-8.

Такие ошибки возникают из-за того, что изменения в php файлах зачастую производятся с помощью обычного Блокнота. Известно, что Блокнот оставляет много “мусора” в сохраненных им файлах — дополнительные посторонние символы и т.п. Все это мешает нормальной работе системы. Проблемы остаются, даже если при сохранении файла Вы вместо ANSI (традиционной кодировки Блокнота) выберете UTF-8.

Один из вариантов решения пробемы состоит в том, чтобы проверить кодировку файлов загруженной Вами темы и поменять ее на UTF-8. Поскольку Блокнот является неудачным инструментом для этого, воспользуйтесь программой Notepad 2, которая является отличным средством для редактирования web-документов.

Скачать Notepad 2

Откройте файлы темы в этой программе, выберете в меню File опцию Encoding, выберите кодировку UTF-8 и заново сохраните.




На сайте

4,088 бесплатных тем